Request: levels for 0.97 version or earlier

Discussion about levels and worlds.

Moderator: SMC Team

Request: levels for 0.97 version or earlier

Postby hcf » 18 Nov 2012 16:58

First of all, hi to all the Secret Maryo Chronicles community. :D

Recently, I have made a port of this awesome game for Xbox (not Xbox 360, but the original Xbox):

viewtopic.php?f=8&t=8683

Now, a lot of Xbox users have known this awesome game and we really love your project, so I'm sure that there are many new fans now. But I am receiving lots of messages asking for more worlds and levels... and the bad thing is that, as OpenGL support is not still completed in Xbox, I had to make the port of the v0.97 version of Secret Maryo Chronicles, because this was the last version that not used OpenGL. In the future, when OpenGL support is completed for Xbox, we would love to port later versions, but nowadays it was not possible.

So, what the Xbox version needs is worlds and levels of the v0.97 version and earlier (maybe some levels of the v0.98 or v0.99 versions can work too, because they used the "txt" format too, before the new "smclvl" format was used).

I know that this is a weird request, but... if anyone has storaged some worlds or levels compatible with the v0.97 version or earlier and could let me know, I would be very gratefull. Furthermore, all the Secret Maryo Chronicles Xbox users will be very gratefull too, because they will be able to play your levels in their consoles too. So, if anyone storaged levels for those old versions, or even if you created your own levels years ago and you want that they were played by the Xbox users and let me know, it would be very nice.

Thank you very much in advance!
hcf
Furball blue
Furball blue
 
Posts: 6
Joined: 19 Jul 2012 16:45

Re: Request: levels for 0.97 version or earlier

Postby Luiji » 25 Nov 2012 18:16

/You could probably write a script to go through the level repository and convert .smclvl's to .txt's. I'd recommend having it skip levels containing fields that cannot be back-ported.

Lucky you that I've got a side project that should solve that OpenGL problem for you...
Custom Built IBM-Compatible (Arch Linux w/ KDE)
Dell Vostro (Windows 7)
Dell Inspiron 1440 (Windows Server 2003, Debian w/ KDE)
Dell Inspiron 11z (Linux Mint)
Luiji
MVP
MVP
 
Posts: 2703
Joined: 14 Jan 2010 23:20
Location: The Mushroom Kyngdom

Re: Request: levels for 0.97 version or earlier

Postby hcf » 26 Nov 2012 11:02

Thank you very much for pointing me to that repository. I will try it! :D
hcf
Furball blue
Furball blue
 
Posts: 6
Joined: 19 Jul 2012 16:45


Return to Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron